R3VLimited Forums

Go Back   R3VLimited Forums > E34/E28 Forums > General 5 Series Discussion

Reply
 
Thread Tools
Old 04-19-2017, 05:56 AM   #1
BMR Jed
Noobie
 
Join Date: Jul 2008
Location: Orange County
Posts: 5
S50 harness v/s M50 harness

Question for the S50 swap experts...

I'm in the middle of an S50/5 spd build on a 92 E34 525iT. Was comparing the harness that's on the S50 and the harness on the M50. On the engine side of the harnesses, looks like the only difference is the oil level sender connector is present on the M50 harness and not present on the S50. Also the Vanos connector is present on the S50 and not present on the M50. Now I'm also looking at another M50 on a 94 525iT which has vanos, so obviously the harness has the vanos connector.

So the million dollar question.

Could I take the engine harness of the 94 525iT with the vanos connector, put it on the S50? If I did this, I think I'll have a home for every connector on the S50.

Also I never quite understood why you keep the DME of the M50 and just change the chip when you do an S50 swap. I would think if you had the DME of the S50, that would be the proper DME to use.

Any insight would be helpful. TIA.
BMR Jed is offline   Reply With Quote
Old 04-19-2017, 11:37 AM   #2
mtech325
Wrencher
 
Join Date: May 2008
Location: san mateo
Posts: 246
There's no reason you couldn't use the 94 vanos m50 harness on an s50. Since you're doing the swap in an e34, the e34 harness is going to fit better than the e36 s50 harness, but essentially they function the same. The e34 harness has the oil level connector, so it'd be nice to have.

The m50tu/s50 run off the same sensors, so any of the vanos equipped engine wiring harnesses will work. For a while, the popular harness was from a 93-94 325is manual car because it was supposedly the most simplified. An auto harness can simply have the auto wiring removed. I think in the case of the e34, the harnesses are the same between auto & manual, but I can't confirm that.

As for the ECU, the reason people like using the m50 "413" red label is because it doesn't have the EWS immobilizer. To run the s50 properly, you get a custom burned chip for about 200 bucks or so. The silver label "413" or s50 specific "506" ECU's will work, but need the EWS deleted. Usually it's a matter of what people have available to them.
mtech325 is offline   Reply With Quote
Old 04-19-2017, 09:01 PM   #3
BMR Jed
Noobie
 
Join Date: Jul 2008
Location: Orange County
Posts: 5
Awesome, thank you for the response. It's very crystal clear now, appreciate the explanation.
BMR Jed is offline   Reply With Quote
Old 05-07-2017, 08:46 PM   #4
noypi2
Grease Monkey
 
Join Date: Jun 2014
Location: San Diego CA
Posts: 379
Just did a S50 swap on my Touring. Touring harness is a direct fit...You will also be using the e34 oil pan so that would take care of the oil level connector.

Sent from my SM-G930T using Tapatalk
noypi2 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:02 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2004 - 2020 R3VLimited LLC