R3VLimited Forums

Go Back   R3VLimited Forums > E30 Technical Forums > Engine & Drivetrain > M10

Reply
 
Thread Tools Search this Thread
Old 05-20-2018, 02:54 PM   #1
loki_
Advanced Member
 
loki_'s Avatar
 
Join Date: Sep 2013
Location: Orlando Fl
Posts: 147
DIY: Delete M10 IAC and cold start injector.

I've run this setup for about 60,000 miles without any issues.














$12 Z1 intake flange

$2.99 vacuum caps
loki_ is offline   Reply With Quote
Old 05-21-2018, 12:44 PM   #2
AEdward
Noobie
 
Join Date: Feb 2016
Location: NJ
Posts: 33
Will try this but Do you have any pics of where the hose from fuel rail goes to? Thanks!
AEdward is offline   Reply With Quote
Old 05-25-2018, 12:48 PM   #3
TobyB
R3V Elite
 
TobyB's Avatar
 
Join Date: Oct 2011
Location: Carnation WA usa
Posts: 4,272
I've also seen the E21 mechanical warmup regulator used...

t
__________________
Quote:
now, sometimes I just mess with people. It's more entertaining that way. george graves
TobyB is offline   Reply With Quote
Old 05-25-2018, 01:28 PM   #4
loki_
Advanced Member
 
loki_'s Avatar
 
Join Date: Sep 2013
Location: Orlando Fl
Posts: 147
Quote:
Originally Posted by AEdward View Post
Will try this but Do you have any pics of where the hose from fuel rail goes to? Thanks!

you'd run one piece of fuel line from the rail to the fuel filter.
loki_ is offline   Reply With Quote
Old 06-17-2018, 11:52 PM   #5
Pavane
Noobie
 
Pavane's Avatar
 
Join Date: Feb 2017
Location: Prescott Valley, AZ
Posts: 17
Thanks for this. How's your idle when the engine is cold and warmed up?
Pavane is offline   Reply With Quote
Old 06-26-2018, 12:30 PM   #6
packratbimmer
Mod Crazy
 
Join Date: Dec 2009
Location: ME
Posts: 782
That should be fine in warmer climates, but warm up here in the north would be difficult.
packratbimmer is offline   Reply With Quote
Old 07-17-2018, 08:42 PM   #7
loki_
Advanced Member
 
loki_'s Avatar
 
Join Date: Sep 2013
Location: Orlando Fl
Posts: 147
Quote:
Originally Posted by Pavane View Post
Thanks for this. How's your idle when the engine is cold and warmed up?


i have my cold idle set at about 950 and warm idle at about 1200. in the winter i have to bump it up maybe a 1/4 turn to account for the colder air decreased the idle.
loki_ is offline   Reply With Quote
Old 12-12-2018, 02:16 PM   #8
jRonin
Noobie
 
jRonin's Avatar
 
Join Date: Nov 2018
Location: Cocoa, FL
Posts: 10
Just ordered a cover today.. mine has all sort of wierd going on.. everything tests okay, but rpm is steady at 1500.. gonna do the delete as a “test” and see if anything changes.

UPDATE: So, it seems my fuel system is set up slightly different (or I’m just being dumb).. there are 2 separate hard lines that come into the engine compartment by the driver side wheel area.. one line goes to the filter, which is then connected to the rail.. The second is routed straight to the pressure regulator.. there’s no T junction to the cold injector, it was routed directly to a second port on the rail.. I’m not sure which fuel line to connect where..

Last edited by jRonin; 12-22-2018 at 04:08 PM.
jRonin is offline   Reply With Quote
Old 12-24-2018, 07:36 AM   #9
jRonin
Noobie
 
jRonin's Avatar
 
Join Date: Nov 2018
Location: Cocoa, FL
Posts: 10
Quote:
Originally Posted by jRonin View Post
UPDATE: So, it seems my fuel system is set up slightly different (or Iím just being dumb).. there are 2 separate hard lines that come into the engine compartment by the driver side wheel area.. one line goes to the filter, which is then connected to the rail.. The second is routed straight to the pressure regulator.. thereís no T junction to the cold injector, it was routed directly to a second port on the rail.. Iím not sure which fuel line to connect where..

Looking for some guidance on fuel line plumbing.. Iíve checked a few other posts, but havenít seen anything regarding what lines to connect where for the cold injector delete.. Gonna start a thread tomorrow if I donít find anything by then.
jRonin is offline   Reply With Quote
Old Yesterday, 01:06 PM   #10
Sonny
Noobie
 
Join Date: Feb 2019
Location: Los Angelas
Posts: 37
I'm doing this now, anybody notice downsides of doing this?

Sent from my Pixel 3 XL using Tapatalk
Sonny is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:28 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2004 - 2020 R3VLimited LLC