R3VLimited Forums

Go Back   R3VLimited Forums > E30 Technical Forums > Appearance & Cosmetic > Interior

Reply
 
Thread Tools Search this Thread
Old 04-19-2019, 05:29 PM   #1
m5james
Member
 
Join Date: Feb 2012
Location: Mill Creek, WA
Posts: 44
Window regulator and wiring issues, could use some guidance.

Bought the GF an 86 325 and it's a great little car but I'm trying to get everything working 100% percent. The latest issue to tackle is the window regulators. When we bought the car only the drivers window would move maybe 1/4" but it's since stopped completely.

Seeing what they cost and not sure if the regulator was the issue or the motor itself, we removed the windows and regulators. Degreased and regreased the tracks until they moved butter smooth. Motors alone bench test fine. Motors attached to regulators bench test fine. Everything installed and plugged back into the car, yet the windows still don't operate via the window switches so I'm at a loss. They don't even light up when the parking lights are on. I removed the window switches, took them apart and cleaned the contacts, applied some dielectric grease and hoped for the best...still nothing. I then ran 12v from the drivers side window switch wiring harness and was able to get the drivers window to move but not the passenger side. When I jumpered the passenger side wiring harness (I had no pinouts, I just touched things in hopes to see window movement) and oddly the drivers window switch lit up...WTF lol. Fuses in the engine bay are good, I'm not sure if there's another fuse box to check.

Before reinstalling the door panels, we rolled them both up manually via the allen bolt but the passenger side put up such a huge fight that it stripped the allen hole while she was cranking it. It was late on a Sunday night so I had the GF throw the door panels back on and I packing taped the crack at the top of the window. Fast forward to next weekend and she pulled the door panels back off starting on the passenger side. Low and behold she missed reconnecting the plugs together, but even after plugging them in, the window still won't operate via the button. I cut a flathead notch where the allen had stripped, but it's still a fight to roll the windows up or down and I have to push the glass from the bottom while manually turning a screwdriver to get the window to close fully. At this point I decided to jumper the motor with everything installed in the car.

https://youtu.be/OetHpxzlwno

Mind you I've only tested the passenger side jumpered to a battery this way, I've yet to have her repull the drivers panel and jumper it. On top of all this, both windows only roll down this far vs going flush with the window seals.

Suggestions?
Attached Images
File Type: jpg 20190417_123831.jpg (59.6 KB, 19 views)
File Type: jpg 20190417_123746.jpg (41.1 KB, 18 views)
File Type: jpg 20190417_123456.jpg (72.3 KB, 16 views)

Last edited by m5james; 04-19-2019 at 05:41 PM.
m5james is offline   Reply With Quote
Old 04-20-2019, 05:44 PM   #2
m5james
Member
 
Join Date: Feb 2012
Location: Mill Creek, WA
Posts: 44
Really? Bump.
m5james is offline   Reply With Quote
Old 04-23-2019, 05:00 PM   #3
m5james
Member
 
Join Date: Feb 2012
Location: Mill Creek, WA
Posts: 44
Fine, this will get some replies...what oil weight should I use for my next oil change?
m5james is offline   Reply With Quote
Old 04-23-2019, 05:38 PM   #4
Zambuzan
Wrencher
 
Zambuzan's Avatar
 
Join Date: Nov 2017
Location: "Mostly Rust-Free" Florida
Posts: 239
Quote:
Originally Posted by m5james View Post
Fine, this will get some replies...what oil weight should I use for my next oil change?
10w40

Pls do a tl:dr next time

Did you try regreasing the motors themselves?
__________________
"Time doesn't heal anything... It just teaches us how to live with the pain." - My Cracked Dashboard
Zambuzan is offline   Reply With Quote
Old 04-23-2019, 05:41 PM   #5
m5james
Member
 
Join Date: Feb 2012
Location: Mill Creek, WA
Posts: 44
I was kidding...already did 15w40 Rotella though.

Tl:dr? I don't know what that means.

I didn't but I guess we could take them back out to clean them. There's a TON of resistance rolling up that passenger window manually though which doesn't make sense to me. My next thought it to loosen ALL the window and regulator bolts and then try again to see if things bind less but at the same time it's not like there's a ton of slop at the bolt holes that would allow adjustment anyways that would cause this much binding.
m5james is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:05 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2004 - 2020 R3VLimited LLC